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A Crash Course in Unity  
o begin, download Unity by visiting http://www.unity3d.com/. Unity 
provides a full version as a 30-day trial with all features unlocked, after 
which it will revert to the free version. The free version includes the 
majority of Unity’s functionality and the Android or iOS tools.  You can 

use the free tool to create and release games.  The main difference between the 
paid and free versions is that the free version includes a watermarked loading 
screen.  If you can live with that, you’re free to develop as many games as you like 
with it.  When the download is complete install Unity and run the software. On 
opening you will notice the Unity Editor is comprised of several tabbed windows 
as shown and explained in Figure 1. 
 

 
Figure 1. The Unity Interface 
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If you didn’t create a new project when Unity started create one now by selecting 
File > New Project from the main menu. The name you give the project will be 
the same as the folder Unity creates to store the game assets. Unity does not use a 
single file to save the project as you find in other software such as Word or 
Photoshop but rather the top-level folder. Unity also likes to have everything in its 
project folders in the correct order, so best not to mess with the structure or add 
anything manually.  

 
Moving in Unity 

To move, rotate or scale an object use the W, E and R keys 
to change the gizmo.  Then drag the axis to put the object 
in the desired position. 

To change the view you can use Q to pan the camera 
(move it vertically or horizontally) or ALT with the right 
mouse button to orientate. 

 

We will now create a simple game scene with a sphere. From the main menu select 
GameObject > 3D Object > Sphere. A new game object called Sphere will be 
created and you’ll see it in the Hierarchy tab and Scene and Game windows as 
shown in Figure 2. When selected the properties of the Sphere are shown in the 
Inspector tab.  
 

 

Figure 2. Adding a Sphere to the Scene 

 
If the Sphere appears small in the Scene, place the mouse inside the window and 
scroll to zoom in. Notice the Sphere in the Game is not affected. The Game is the 
view of the game from the camera in the scene. The camera is essentially the 
player’s eyes into the game world. You can find the Main Camera as a game object 
in the Hierarchy. Double-click on it.  
 

 

K E Y S  

W     Move 

E    Rotate 

R    Resize 

Q + Mouse Pan View 

ALT + Mouse Rotate View 
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To change what you see in the Game the Main Camera needs 
to be moved. To do this, select the Main Camera in the 
Hierarchy and press W. A set of green, red and blue axes will 
appear in the Scene on the Main Camera. To move the 
camera select the tip one of the axes with the mouse and drag 
it. Notice how the Game view changes with the camera’s 
view. 

To change the camera’s orientation, with the Main Camera still selected in the Scene, 
press E. Green, red and blue orbital handles will appear around the camera in the 
Scene. Dragging the mouse over any of these will orient the camera. 

The final manipulation you can make to an object in the Scene is to scale it. In this 
case, scaling the camera won’t do anything, so instead, click on the Sphere either in the 
Hierarchy or the Scene. Press R. Again green, red and blue axes will appear. This time 
the axes will have small cubes on the end. There will be a large yellow cube in the 
centre. Dragging the large yellow cube will evenly resize the Sphere. Dragging the 
individual cubes at the end of each axis will resize in the same direction. Try this out 
and observe how the sphere’s size changes in the Game. 

Try pressing the play button at the top centre of the editor.   This runs 
your game. At this time nothing will happen as there’s nothing actually going on in 
your scene. Press the play button again to stop playing. 

NOTE:  Do not make changes to your game in Play mode.  Otherwise when you stop 
playing the changes will be lost. 

 

You may have noticed the sphere looks very flat in the Game. 
This is because there aren’t any lights. When lights are added to 
a scene 3D objects become shaded and the scene gains depth. 
To add a light select GameObject > Light > Directional Light. 
The sphere will now be shaded. 

 

To add physics, with the Sphere selected, choose Add Component 
> Physics > Rigidbody. The result will be a Rigidbody component 
added to the Inspector for the sphere. For the Sphere, having a 
rigidbody simply means it becomes part of the engine’s physics 
system and now will behave as such. 

Press play. The Sphere will fall under the influence of gravity. 
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Add a cube to the scene with GameObject > 3D Object > Cube. Select the Cube 
in the Hierarchy and use the W key to set it to move mode and use the mouse to 
drag the cube beneath the sphere. Add a rigidbody to the cube. Without changing 
any rigidbody settings, press Play. Both the sphere and the cube will fall at the 
same rate. If you understand basic Newtonian physics there will be no surprises 
there. For the Cube, in the Inspector, untick the rigidbody’s Use Gravity tickbox. 
The cube will still be influenced by physics events just not gravity.  
 
Play. The Cube will remain stationary until the sphere collides with it, causing it to 
move under the sphere’s influence.  
 
Add more Cubes and place them beneath the Sphere. To add an exact replica of the 
Cube you’ve already created, with it selected in the Hierarchy press CMD+D (Mac 
OS) or CTRL+D (Win) to duplicate it. Right-clicking on the object in the Hierarchy 
will also give you the option to duplicate. You can then move the new Cube into 
position. Because it was duplicated it will already have a rigidbody. Depending on how 
you have the cubes positioned, the Sphere will now collide with them and cause them 
to spin. The Sphere will continue falling under the influence of gravity, but the Cubes 
will only have the Sphere’s momentum on collision to carry them and therefore they 
will not fall in the same way. 

NOTE: If you want to set the Main Camera to look at the game world in the same way 
you are viewing it in the Scene, select the Main Camera and then GameObject > Align 
with View. 

 
Another property you can manipulate on a game object is 
its colour. The colour is defined by a material component. 
It must be created differently to the physics component. 
To create a material, go to the Project, select the drop 
down menu under Create and choose Material.  
 

 

When the material is first created it will be called 
New Material. Click on its name to change it to Green. 
When it is selected in the Project, the properties of 
the material will be visible in the Inspector. Click on 
the Main Color colour box to bring up the colour 
selection dialogue. Set the colour of the material to 
green. 
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To apply the material to one of the game objects in the Scene simply drag and 
drop the material from the Project onto the object in the Scene. Alternatively you 
can drag and drop it onto the game object’s name in the Hierarchy or with the 
game object selected in the Hierarchy, drag and drop the material onto the 
Inspector.  
 
You can apply this material to any object in the Scene. To change the colour or other 
properties of the material, select it again in Project and change it in the Inspector. All 
objects with this material applied will change in response. For example, if you changed 
the colour of the material to orange, all objects that were green will now appear orange. 

 

Code can be attached to any game object to control it’s behaviour.  Simple JavaScript 
commands can access and modify any properties.  For example, you can change the 
colour of the object, move it around, change it’s animation state and much more. 

To create a script, in the Project select Create > Javascript.  The file will initially be 
called NewBehaviourScript.  Click on it and rename to revolve.  Double-click the new 
file in the Project to open it in an editor. 

Add the line of code in bold to the script and then save. 

#pragma strict 
function Start () { 
} 
 
function Update ()  
{ 
 this.transform.Rotate(Vector3.up, 5); 
} 
 

Switch back to Unity. 

Drag and drop the script file onto one of the cubes in the 
Inspector.  This will attach the script to that particular game 
object and cause it to follow the instructions of the code. 

Play.  Watch the cube spin.  

Attach this code to any object in the scene that you want to spin. 

  

STEP  10 

 

STEP  11 

 

STEP  12 

 



M O B I L E  G A M E S  W I T H  U N I T Y  

6 

Slender Granny 
Making an avoid and collect game for a mobile device. 

n this tutorial we are going to make a game in which the player must run 
from one side of a map to the other, avoiding zombies, picking up chests to 
stay alive and reaching a tower before their health runs out. 
 

To begin, download the starter files from the website at 
http://www.holistic3d.com/Tutorials/SlenderGranny.pdf and open the gamplay.unity 
file in the Unity project folder SlenderGranny by double-clicking on it. 

 

 

 

 

 

 

Unity will open 
and you’ll see a 
large blank 
ground plane 
and a simple 
graphical user 
interface (GUI) 
as shown here. 

 

Part 
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STEP  1 

 



M O B I L E  G A M E S  W I T H  U N I T Y  

7 

 

Add Granny 

In the Project > Prefabs folder locate the Sporty_Granny prefab.  Drag and drop it 
into the Hierarchy.  The Sporty_Granny character will be added to the scene. 

 

Press the play button and use the arrow keys to move Granny around. 

Turn on the Lights 

So granny can see where she is 
going we should add a light to the 
scene.  From the main menu 
select GameObject > Light > 
Directional Light.  There will now 
appear a Directional Light game 
object in the Hierarchy.  Selecting 
it will reveal its properties in the 
Inspector. 

STEP  2 
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We want the game to be dark and scary so set the light’s intensity to 0.2 and turn on 
soft shadows. 

 

Attach Camera to Granny 

In the current game state Granny is able to walk out of view of the camera.  In third-
person games, such as this, the camera sticks to the character and follows it around.  
To achieve this in our game, the camera is childed to the character.   

Select the Main Camera in the Hierarchy and drag and drop it onto Sporty_Granny. 

 

Click on the little triangle next to Sporty_Granny in the Hierarchy to see the other 
children of that object.  After dropping the camera onto the character it will now be 
one of these children. 

This means that wherever Sporty_Granny goes, so will the camera. 

Align the Camera with Granny 

Press play and walk Granny around.  Does the camera follow and stay fixated on the 
character?  If it is a little askew, you may want to adjust the camera’s position and 
rotation with respect to Granny.  To do this, select the Main Camera in the Hierarchy 
and set its position to (0, 2, -4) and rotation to (5, 0, 0). 

STEP  4 

 

STEP  5 
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Feel free to modify these values as you like until the camera is the position you want it.  

Sculpting the Environment 

For this game we are using a Unity terrain.  This is a 3D model that can be edited 
within Unity.  But pulling and prodding at the surface you can create hills and valleys to 
your hearts content.  There’s also the ability to add trees, grass and paint the landscape. 

The terrain in this game is called (funnily enough) Terrain.  Locate it in the Hierarchy 
and select it.  It’s currently flat and green as you can see in the Scene view. 

The terrain editor has a number of options for creating a 
landscape.  Play around with them as you like to see how 
they work. 

Select an option and then drag the mouse over the terrain 
in the Scene view to change it.  SHIFT+RightMouse Drag 
will undo any changes.  Use the shift to remove trees or 
lower the height. 

For the painting textures, adding trees and adding grass 
options images and models are already preloaded.  You will 
NOT need to use the Edit Textures button.  Just stick with 

the ones already loaded. 

Under the tree adding option, you will find a button that will 
perform a mass planting of trees.  This works well to add a large 
crop of random trees over the terrain.  Keep in mind you are 
creating a game that will eventually be pushed out for mobile and 

therefore you should limit the 
number of trees This game will 
have Granny running across it 
from one side to the other to 
reach a tower.  Create a 
landscape with a mount for the 
tower on the other side of the 
terrain from Granny’s starting 

T E R R A I N  E D I T S  

     Raise and Lower 

  Plateau 

  Smooth 

 Paint Textures 

Add Trees  

 Add Flowers/Grass 
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position.  Give the landscape some interesting features and vegetation. 

At anytime you can press play and have Granny run around the map.  You may like to 
do this to ensure the terrain isn’t too steep for her to navigate.  Some steep parts are 
okay, but it can’t be impossible to get the 
character to safety. 

If you run the game and Granny walls through 
the ground and into the abyss chances are the 
capsule collider that determines Granny’s 
physics and keeps her planted to the ground has 
gone through or below the terrain.   

To fix this, with Granny selected in the 
Hierarchy, press the W key to get the movement 
axes to come up in the Scene and use the up 
pointing arrow to drag Granny above the 
ground. 

Press play to check you’ve lifted the model up 
far enough.  Even if it is slightly in the air above 
the terrain when you press play, gravity will ensure Granny drifts to the ground. 

Add the Tower 

Granny’s safe haven and the checkpoint that ends the game is the tower.  The tower 
will be placed on the other side of the map.  For the tower we need a 3D model.  This 
Locate the Watchtower prefab in the Project > Prefabs folder and drag and top it onto 
your terrain.   

It doesn’t matter if you don’t get it in 
the exact position as you can move it 
around in the same way we adjusted 
Granny’s position in the previous 
section. 

After the tower is in the Scene, select 
it and then press the W key.  Drag the 
tower around by the blue, green and 
red axes that appear. 
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Land of the Living Dead 

To give Granny that little bit of incentive to make it to the 
tower we will now add a horde of attacking zombies.   

Locate the globalFlock script in the Project > Scripts folder.  
Drag and drop it onto the GameHUD object in the Hierarchy. 

Select the GameHUD object in the Hierarchy and you will now 
see the script attached to it in the bottom of the Inspector. 

With GameHUD selected in the Hierarchy, drag and drop 
Sporty_Granny from the Hierarchy onto the Granny variable 
box of Global Flock in the Inspector and drag and drop the 
Zombie prefab from the Project > Prefab folder onto the 
Zombie variable. 

 

 

 

It’s very important 
you get the right 
Granny and the right 
Zombie dropped 
onto the Global 
Flock script. 

 

 

Once you’ve completed this step Play the 
game and take Granny for a walk.  Watch out 
for the zombies. 

STEP  8 
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They will follow you around unrelentlessly until you are dead. 

 

The Cries of Death 

When Granny finally succumbs to the zombie attack there’s a spectacularly over acted 
death animation that plays.  This is great visual feedback for the player.  But lets make it 
even better by adding a little sound. 

With Sporty_Granny 
selected in the 
Hierarchy, click on the 
Add Component 
button in the 
Inspector.  From the 
list choose Audio > 
Audio Source. 

An Audio Source 
component will be 
added to 
Sporty_Granny. 

The Audio Clip of this 
Audio Source should 
be set to the death.mp3 
file that can be found 
in the Project > 
Sounds folder. 

After the Audio Clip is set, 
untick the Play On 
Awake check box.  If you 
don’t the sound will play 
immediately the game runs. 

Then click and drag the 
entire Audio Source by its 
text at the top near the little 
orange speaker symbol and 
drop it onto the Dying slot 
of the Granny Controls 
script just above. 

To test this worked.  Play 
and take Granny for a walk 

STEP  9 
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in the forest to meet her doom. 

 

Add Scary Background Adding a Backing Track 

To add another level of scary ambience to the game lets play some scary backing 
music.   

Select the GameHUD in the Hierarchy.  In the Inspector, use the Add Component 
button to add an Audio Source onto the GameHUD.  Set the clip for this Audio to the 
backgroundMusic file in the Project > Sounds folder and tick its PlayOnAwake and 
Loop checkboxes. 

 

Play. There’s now scary music. 

Health Pickups 

By now you’ll have figured out that Granny has no hope in this zombie ridden 
landscape with rapidly declining health to make it to the tower alive.  We therefore 
need to provide her with some pick-me-ups – health boosts – to provide her with a 
fighting chance. 

 

STEP  10 
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Double-click on Sporty_Granny in the 
Hierarchy to locate your in the Scene.  Drag a 
Treasure_Chest prefab from the prefabs 
folder onto the terrain close to Granny.   

Play.  Have Granny walk over the chest.  Once 
it is picked up a sound will play, a score will 
float up and Granny’s health bar will increase. 

If you inspect the Treasure_Chest you’ll find it 
is more than a 3D model. It also has script 
attached and an Audio Source among other 
things. 

Now, you could place chests by hand all over the map.  But this is a laborious task.  
Instead, a simple script can be employed to create and drop chests at random across 
the landscape. 

Locate the addRandomObjects script in the Projects > Scripts file.  Drag and drop this 
script onto the Terrain. 

Select the Terrain in the 
Hierarchy.  Drag and drop the 
Watchtower and 
Sporty_Granny objects from 
the Hierarchy onto Obj1 and 
Obj2 of the script respectively. 

Drag and drop the 
Treasure_Chest prefab from 
the Project onto Gobj of the 
script. 

This script will drop chests at 
random locations within a circle 
between the tower and Granny. 

 

Sometimes a prefab is dropped onto a script.  You do this when you want to create 
copies of the prefab and add them to the scene.  To manipulate or work with objects 
already in the scene (such as Granny and the tower) the script needs to reference them 
directly from the Hierarchy. 
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Play.  You’ll find a whole cache of chests have been dropped on the map to give 
Granny a little boost every time she walks over one. 

‘See?’ said the blind Granny 

With all the zombies and chests scattered across the terrain it would be nice to give 
Granny a little heads-up as to their location.  We will therefore add a radar system to 
the game. 

Locate the radar script in Project > Scripts and drag and drop it onto the GameHUD 
object in the Hierarchy.  This script performs some clever mathematics and places 
coloured dots on a radar view on the game heads-up display (HUD). 

However, to perform its task it requires some images; ones to display locations of 
chests and zombies, one to show where the tower is and others. 

Expand the view of the 
Project > Textures folder 
so you can see all the 
images contained within.  
Next select the GameHUD 
object in the Hierarchy.  
You will now see the radar 
script in the Inspector.  
One by one drag the 
corresponding images onto 
the script from the 
Textures folder as shown 
here. 

You’ll also need to drag 
Sporty_Granny from the 
Hierarchy onto this script 
so the radar can figure out 
the position of objects 
relative to her position in 
the world. 

Play.  You will now have a radar system.  The green dots are the chests, the red dots are 
the zombies and the gold arrow points to the tower. 

Are we there yet? 

the tower.  If this number is going down, we know the player can assume they are 
heading in the right direction. 

STEP  12 

 

STEP  13 

 



M O B I L E  G A M E S  W I T H  U N I T Y  

16 

There’s already some text on the screen in the upper right ready to display this value.  
All we need to do is program it in. 

Double-click on the script file CalcTowerDistance in the Project >Scripts direction.  It 
will open in a code or text editor.  Type in the following code: 

#pragma strict 
 
var granny: GameObject; 
var tower: GameObject; 
 
function Update ()  
{ 
 var d: int =  
         Vector3.Distance(granny.transform.position,  
                          tower.transform.position); 
 this.GetComponent(Text).text =  
         "Tower in " + d + "m"; 
} 
 

Save the file but don’t close the editor (just incase you’ve made a mistake).  If you ever 
make a mistake in the code you’ll get an error message in red across the bottom of the 
editor window.  Double-clicking on the error message will provide more information. 

 

If there are no errors in your code the bottom of the editor window will be clear of 
messages. 

Next, locate the 
TowerDistance game 
object in the 
Hierarchy.  Drag and 
drop the 
CalcTowerDistance 
script from the 
Project and drop it 
onto TowerDistance.  
Select 
TowerDistance in 
the Hierarchy to 
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expose the script in the Inspector. 

The script requires knowledge of Granny and the Tower in order to calculate the 
distance between them.  Drag and drop Granny and the Tower game objects from the 
Hierarchy onto these boxes in the Inspector. 

Play.  The upper right corner of the HUD will show a changing distance to the tower 
value. 

Some final touches 

Imagine.  Granny finds herself in the dark, surrounded by zombies, health rapidly 
declining. The forest would be gloomy and the grass damp. She’d be panicked, right?   

To set the scene even more we can darken the sky, add some fog and more sounds. 

To darken the sky select the 
Main Camera that is attached 
to Sporty_Granny in the 
Hierarchy.  In the Inspector 
click on the Background 
property to bring up the 
colour selection box.  Set the 
background colour to a 
gloomy grey. 

You can also set the colour 
by typing in the Red, Green, 
Blue and Alpha values of 82, 
85, 86 & 5 respectively into 
the colour sliders. 

In the Scene and Game views 
the sky will now be grey. 

Of course, if you prefer, the sky can be green, red or pink.  Its up to you! 

Fog 

To add fog to the scene select 
from the main menu Edit > 
Render Settings.  In the 
Inspector window a render 
settings dialog will appear.   

Turn on the fog by clicking 
the Fog check box.   

STEP  14 
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Its important to know that the sky is not affected by the fog colour.  Therefore, if you 
want a seamless blend between the sky and distant fog you’ll need to make the fog 
colour exactly the same colour as the sky. 

Change the fog density value to get thinner or thicker fog as desired. 

At anytime you can Play and take Granny for a job through the fog to check the 
density and colour is just right. 

Zombie Moans 

To inform the player there 
are zombies nearby, lets play 
a zombie moan sound when 
the game first runs. 

Select the GameHUD in the 
Hierarchy and add a new 
Audio Source to it (Add 
Component > Audio > 
Audio Source).  Set the 
Audio Clip of the new source 
to the zombie sound clip. 

Click the PlayOnAwake 
checkbox. 

Play.  A zombie moan will 
play as soon as the game 
loads. 

Footsteps on Wet Grass 

We can further engagement with the game by adding 
footstep sounds to Granny. 

Select Sporty_Granny from the Hierarchy and add 
an Audio Source to her, just like you did with the 
zombie moans above.  Set the Audio Clip to the 
running sound.  Turn off PlayOnAwake. 

Granny’s footstep sounds need to begin when she 
runs and end when she stops moving.  The Granny 
Controls script already attached to Sporty_Granny 
controls this for you.  You just need to give it a 
sound.  Drag and drop the new Audio Source with 
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the running clip onto the Granny Controls script and into the Run Sound box. 

Play.  You will hear footsteps with Granny runs. 

Puffing from Exhaustion 

You can add as many sounds to a scene as you like.  Along with the footsteps we will 
now add a puffing sound.  The procedure to do this is exactly as that for adding the 
footsteps. 

Add a new Audio Source to Sporty_Granny, set the Audio Clip to the puffing sound 
and then drag and drop this Audio Source onto the Granny Controls script in the Puff 
Sound box. 

Play.  Granny will puff when running. 

If you get the sounds play immediately when the game loads it will be because you’ve 
forgotten to uncheck PlayOnAwake. 

Celebration Sound 

There’s another clip called alright in the Project > Sounds folder.  This sound will be 
used later, but while you are adding sounds to Sporty_Granny, now is probably a good 
time to add this.  Follow the same steps you did for adding puffing and running to add 
the alright sound as an Audio Source.  Set the Win Sound box of the Granny Controls 
script to this new Audio Source. 

Reaching Safety 

If you’ve tried the game thus far you’ll find that reaching the tower does not ensure 
safety.  As of yet we’ve not programmed the game to recognize when Granny reaches 
it. 

Locate the reachTower script in Project > Scripts.  Double-click to open in the script 
editor.  Enter the following code: 

#pragma strict 
 
function OnTriggerEnter(other : Collider) 
{ 
 if(other.gameObject.tag == "granny") 
 { 
  ginterface.winner = 1; 
 } 
} 
 

STEP  15 
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Select the Watchtower object in the Hierarchy.  Drag and drop reachTower from 
Project > Scripts onto it. 

When Granny reaches safety we should celebrate with a new backing track.  Select 
GameHUD from the Hierarchy and add another Audio Source.  Set the clip to 
funk_01 from Project > Sounds.  Turn PlayOnAwake off. 

The Ginterace script on the 
GameHUD controls the 
background music.  It will 
need to turn off the 
background music and turn 
on the celebration music.  
You therefore need to set 
the Win Music and Back 
Ground Music boxes for 
Ginterface to the 
associated sounds. 

As before drag and drop 
the appropriate Audio 
Sources that are attached to 
the GameHUD onto the script. 

Testing the Tower 

To test this is working you could play and run Granny all the way across the map to 
the tower, or you could test the end game condition for bugs without running through 

the entire scenario. 

In the Scene, zoom in on 
the tower.  Select 
Sporty_Granny in the 
Hierarchy and then from 
the main menu choose 
GameObject > Move to 
View.  The Sporty_Granny 
object will be relocated 
near the tower.  You might 
have to manipulate the 
position of the model with 
its axis to ensure it is 
slightly away from the 
tower and also above the 
terrain. 

STEP  16 
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 Sporty_Granny can also be moved by selecting the game object in the Hierarchy, 
pressing W and then using the axes system to move the model into place. 

Play.  You’ll find a plethora of chests between Granny and the tower.  This is because 
the script that randomly creates the chests makes sure they are between the objects.  So 
it creates all the chests in a small space. 

Ignore this effect though as you are here to test the game over scenario. 

Run Granny at the tower.  When she is close enough the game will be over and a little 
surprise awaits you! 

Game Tweaking and Testing 

The game is now complete.  Move Granny back to the other side of the map and play 
through the scene to see if you can beat the zombies to the tower.   

If you want to tip the odds in your favour you can play around with the variable 
settings for the game.  You’ll find these in the settings script attached to the Settings 

 

Stop the game while you change these settings and then recommence.  Note: the game 
is achievable with the default settings!! J 

Control for Tables: Adding a Joystick 

Tablet devices don’t have a keyboard.  This 
will leave Granny a little high and dry or 
battered and bloody as the case may be. 
Luckily, Unity supplies a joystick controller 
for our use. Locate the Joystick prefab in the 
Project > Prefabs folder and drag and drop 
it into the Hierarchy.  If you switch to the 
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Game view you’ll see the joystick graphic in the bottom right hand window. 

Now to hook this up with 
Granny’s controls select 
Sporty_Granny in the 
Hierarchy then drag and drop 
the new Joystick from the 
Hierarchy onto the Granny 
Controls script in the space 
provided called Js. 

When you build out to a 
tablet device there will be a 
way to move Granny around. 

Building for other platforms 

Unity has the ability to build to a 
multitude of platforms.  You can 
change the platform in the build 
settings window.  

PC/Mac 

To make a stand alone PC or Mac 
game select the PC, Mac & Linux 
Standalone platform and then click 
on the Switch Platform button.  
Select the Target Platform on the 
right and then click the Build 
Button. 

The files produced can be copied 
onto a USB and run on another 
machine. 

Web 

To create a web game, select the Web Player platform, Swith Platform and then Build.  
Unity will create two files.  One with .unity on the end and one with .html.  Keeping 
these files together in the same folder you can open the .html file with a web browser 
and play the game.   

These two files can be uploaded onto a website and run. 

You’ll find an example of Slender Granny here:  

http://aliveed.com/slendergranny/ 
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Android 

To build out to an Android device you will need an android device plugged in via USB 
to the computer.  You will also need the Android SDK installed and any other ancillary 
programs.  Then it’s a matter of clicking on the Build Button. 

For detailed steps see: http://docs.unity3d.com/Manual/android-sdksetup.html 

iOS 

To build out to an iOS device (iPad, iPhone) you need to have the device plugged in.  
You also need to have XCode installed on your Mac and an Apple Developer account. 

For detailed steps see: http://docs.unity3d.com/Manual/iphone-GettingStarted.html 
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Like to Learn More? 
Unity is a free game development engine.  It can 
be downloaded from http://www.unity3d.com. 

I’ve two books that can help you get started 
with programming Unity to create your own 
desktop and mobile games.  The books were 
written for students and are used in over 40 
universities internationally as a text. 

They are aimed at the novice and begin gently 
leading the reader through numerous simple 
exercises up to complete games. 

Read more about them at: 

http://www.holistic3d.com 

Unity also has a comprehensive set of video 
tutorials for beginners at: 

http://unity3d.com/learn 

Contact Me 

For more information or help with Unity or 
associated game creation matters feel free to 
contact me via email or on social media. 

Penny de Byl 
pdebyl@bond.edu.au 
Twitter:  
@penslayer 
Facebook:  
https://www.facebook.com/pdebyl 
https://www.facebook.com/pages/Holistic3D/272575919455432 
 

More about Bond’s Bachelor of Interactive Media and Design 
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